Hallo! Ich habe einen Linksys WRT54GL und darauf openWRT-kamikaze installiert. Da der Router in einem Lokal benutzt wird, hängt ein Lokal-PC (für die Lokal-gäste), die Kassa, der Bankomat und ein Bürorechner drauf. Um nicht vollen Zugriff z.B vom Lokal-PC auf die Kassa oder auf den Bürorechner zu zulassen, habe ich die einzelnen switch-ports des wrt54gl in jeweils ein anderes vlan gegeben:
Code:
config switch eth0
option vlan0 "0 5*"
option vlan1 "4 5"
option vlan2 "1 5*"
option vlan3 "2 5*"
option vlan4 "3 5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface uplink
option ifname "eth0.4"
option proto static
option ipaddr 192.168.1.100
option netmask 255.255.255.0
config interface gnb
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.101
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
wie kann ich jetzt das routing zwischen VLAN0 und VLAN4 aktivieren, sodass alle pakete geroutet werden (filtern kann ichs dann ja eh über die firewall, aber zuerst muss mal das routing funktionieren)?
ich kann vom openwrt den lokalpc und den büropc pingen, nicht aber vom lokalpc den büropc (bzw. umgekehrt)